Follow

I receive an "GetAuthorization Error -4: AUTHORIZATION NOT PRESENT/GetAuthorization Error -1: INITIALIZATION FAILURE" error when I run the Checklic licensing utility. (KB545)

Question Detail

When running the Checklic license utility, I get the following error messages:

GetAuthorization Error -4: AUTHORIZATION NOT PRESENT
GetAuthorization Error -1: INITIALIZATION FAILURE

Solution

You may see this error after a new installation of the LonMaker Integration Tool or an LNS application. If you see this error, try to create and open a network database. This may resolve the error.

If you still get a license error when opening a network database, the license is corrupted. The only way to recover from this error is to replace your LonMaker or LNS Device Credits. Run the LonMaker license wizard if you are fixing a LonMaker credit problem, or the Echelon LNS Server license wizard if you are using another LNS based tool or application.

To start the LonMaker license wizard, click the Add Credits button after you get an error message while trying to open the network.

To start the LNS license wizard, click Start > Programs > Echelon LNS Utilities > LNS Server License Wizard. This wizard is not the same as the LNS License Transfer Wizard.

Once you generate the credit order form using the appropriate wizard, fill in your contact information and select the box in the "Replacement" section in the form. Then send your request to credits@echelon.com for replacement credits. Only request the number of credits that you have not yet used, as follows:

 

(number of replacement credits) 
    = (number of purchased credits) - (number of credits used)

For example, when you purchased the LonMaker Professional Edition, it came with 64 device credits. If you commissioned 5 devices and have not since purchased any additional credits, the number of replacement credits is 64 - 5, or 59.

For LNS 3.0 only: Once you have fixed your license, download and install the LNS Licensing Update 2006. LNS Turbo already has this update.

See KB540 for additional information on license questions/issues.

Related Products
  • LNS 3.0
  • LNS Turbo Edition (Ver 3.2)
  • LonMaker 3.0
  • LonMaker 3.1
  • LonMaker Turbo (Ver 3.2)
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk